VisualStudio 2015 doesn't load any project Types, After disabling some Features?

visual-studio
windows

(this.is.sparta) #1

Hi,

I disabled some few Windows 10 Features a day ago, and now when i try to open my Visual Studio projects, i get Some weird Exception such as “Null Reference Exception” and Visual Studio fails to open the project, but yet it cannot be turned off either without doing that through Tasks manager, and when i try to create new project it doesn’t load any Project type in the New Project dialog Box. i tried re-Enabling the Windows Features but nothing, i tried to repair Visual Studio 2015 but still the same.

Here are the symptoms in short:

  • Disabled Windows 10 Features.
  • Visual Studio Fails to load Any Project types.
  • Visual Studio is unable to open any project type.
  • Visual Studio Can’t be turned off after trying to load any project.

Please help this is very critical.

Thanks.


(Sine) #2

you should re-install Visual Studio 2015, and check again if it works.


(Kunni Can) #3

I had similar situation couple weeks ago, i tried Repairing Visual Studio 2015, but that didn’t work well, it was the same after repair, i tried re-installing Visual Studio 2015, but that didn’t work well as well (it was the same again). and then i did the following which worked perfect:

  • Uninstall Visual Studio 2015, entirely.

  • Remove “AppData” and “Program Files” related to Visual Studio 2015, alone (usually under directory “Microsoft Visual Studio 14.0” or anything named “Visual Studio 14.0”.

  • Restart your computer (might not be necessary but better do).

  • Install Visual Studio 2015 again. (it should work now).

  • that’s it.

I believe this happens because you disabled some Windows Features while Visual Studio is running or something.