Why Google Maps Geocode Keys Stopped Working?

I suddenly started getting this error :

This API project is not authorized to use this API. Please ensure this API is activated in the Google Developers Console: For more information on authentication and Google Maps Javascript API services please see:

Google Maps Geocode keys were working properly before, and the problem only appeared yesterday, I am using Google Maps geocode API to get Addresses auto complete suggestions.


make sure the Library API below is enabled :

  • Google Places API Web Service (enabled)

Here is how you enable the service “Google Places API Web Service” as @jms said :

  1. In your Google API dashboard go under Library:
    Stopbyte - Google API library

  2. Search for “Google Places API Web Service”:
    Stopbyte - Google API Places Web Service Search tool

  3. Click the Appropriate Library in search results:

NOTE: In case you are using this API for an Android or iOS App, you will have to use the other Libraries “Google Places API for Android” or “Google Places API for iOS”.

  1. Finally on the Library you, will find an “Enable” button click it, in case it says “Disable” that means the library is already active:

The same thing works for all different Google API libraries.

Hope that helps anyone.


the solution that might work for you as well, would be making sure that the Geolocation and Geocoding web services are both enabled.

By the way; in some cases after enabling the services you will have to wait up to 10 minutes for your changes to take effect.

1 Like

if none of the solutions suggested above didn’t work for you (though that’s awkward) you have one last chance of checking your QPM or QPS (Quota Per Month or Quota Per Second) as that can cause the problem as well, check your Google API dashboard if you reached your quota limit.
If you did reach the quota limit wait for it to reset, or add pauses to your code.

1 Like

Very perfect answer :slight_smile: thanks @Yassine I was googling that and It brought me here :blush:

I lost 2 days fixing this problem. Thanks a lot!!!