How to solve VirtualBox Error: "Callee RC: REGDB_E_CLASSNOTREG (0x80040154)"

virtualbox

(jms) #1

Hello;

After many days without running VirtualBox, i decided to do that today. but i got surprised that it wont run at all.

i tried all other websites to and VirtualBox Forums, but seems like no suggestion solution there works for me.

I get this error when i run my VM:

"Failed to create the VirtualBoxClient COM object.

The application will now terminate.

Callee RC: REGDB_E_CLASSNOTREG (0x80040154)"

Failed to create the VirtualBoxClient COM object.  The application will now terminate. Callee RC: REGDB_E_CLASSNOTREG (0x80040154)

i tried every trick in the book to get it fixed but nothing worked.

Can you please suggest what to do?

thanks


How to boot Qemu Virtual machine from a live CDROM ISO image?
Virtual Box Virtual Machine Fails to launch
(jms) #2
  • EDIT:
    I thought to add this here, as I actually went through a similar situation again with this annoying VirtualBox critical error com object, and found this step-by-step tips very helpful:
  1. Go to your Start Menu / or wherever your VirtualBox is installed.
  2. Find the Oracle VirtualBox application in there.
  3. Right click through it, and go to Properties.
  4. Under the Compatibility tab you can find an option (check box) to run the program in compatibility mode.
  5. Check that box if it’s not already, and you will be given options to choose which Windows version you should make it compatible with.
  6. Pick one by one, from the most recent version (Windows 10) up to the oldest one, you will mostly find the VirtualBox you are running compatible with Windows 7 or Vista.
  7. Apply & Save your changes and run VirtualBox.
  • Hope these new edits might be helpful to anyone out there, these are a bit more generic and might/might not work in all cases so for very custom solutions and cases probably you’ll have to either go through the other solutions within this question page, or ask a related question specific to your case.

Thanks all for your answers above, unfortunately, none of your suggestions worked for me though they really guided me through to find the cause of the problem and how to solve it.

I’ve re-registered the service, but that only allowed the VirtualBox to run. And then when running a VM in VirtualBox it fails and crashes. I’ve checked the logs to find that the log stops after Loading the file comctl32.dll. that gave me the hint that some windows update messed up that file.

So, unfortunately, the only solution that worked for me is repairing windows 7. and it did work after that.

Edit:
For anyone interested, you can as well restore to some backup point before installing the updates (that if you suspect any update to cause that).
And of course, the only way possible to avoid such trouble in the future is disabling Windows updates.

Note: I tried all different older & newer versions of Virtual Box, and every time I’ve encountered that issue so for sure it’s not a bug in VirtualBox. so no need to report that to VirtualBox forums.


(Yassine) #3

I believe it’s windows Updates that messes it up. after I installed couple updates I regret it (unfortunately can’t roll it back).

but some of my friends found it useful to execute these commands:

Run your cmd and set the current directory ‘cd’ to the directory where VirtualBox is installed (usually "C://Program Files/Oracle/VirtualBox") afterward execute the commands below:

VBoxSVC.exe /ReRegServer
regsvr32.exe VBoxC.dll

though that didn’t solve my problem, hope it solves yours.

Re-installing VirtualBox Worked for me though as suggested above.


VirtualBox hangs when running a VM at "Creating process for virtual machine" (GU/Qt)....(1/2)"
(jms) #4

I believe you forgot to mention that the cmd must be run as Administrator, otherwise the service registration will fail.


(this.is.sparta) #5

Try to check your VirtualBox Logs probably they will have some helpful information for you.

For me - though the answers above saying that windows updates are causing the problem with VirtualBox- I only had to install windows updates to get the problem solved. and I believe that windows updates were the cause for the issue for me too.


(jms) #6

@sparta that didn’t help either :confused: VirtualBox Logs were not that helpful at all!


#7

@Yassine
Thanks this worked and as @jms suggested I used Admin privileges or else I got another error:
The module VBoxC.dll was loaded but the call to DLLRegisterServer failed with error code 0x80070005.

Note: I have been copying my VirtualBox around to other drives and didn’t want to keep reinstalling and this solution works fine every time.

Solution using Batch files:
Create the batch file then right click and Run as Administrator. Don’t forget to change to respective paths; I’m using the D: drive. I created one for installed and another for portable version, so two different batch files but you can combine them or just use one.
First Batch file:
REM Installed-VirtualBox
D:
CD D:\Program Files\Oracle\VirtualBox
VBoxSVC /ReRegServer
regsvr32 VBoxC.dll
Exit

Second Batch file:
REM Portable-VirtualBox
D:
CD D:\VM\Virtual Box Installation\Windows 10\Portable-VirtualBox\app64
VBoxSVC /ReRegServer
regsvr32 VBoxC.dll
Exit